Unable to log in post SquaredUp DSv4.4: "SCOM connectivity error: unknown or non-specific error"

Error Message on logon screen

Unable to log in after an upgrade or a new install of SquaredUp DS v4.4 and above, you may get one of the following messages:

"An unknown error occurred when logging in"

or

"Datasource authorization unsuccessful"

Error Message in the log files

The SquaredUp DS rolling.log file includes the following (for help see Where to find log files):

YYYY-MM-DD HH:MM:SS.xxx >> XXX >> [ERR] SCOM connectivity error: unknown or non-specific errorMicrosoft.EnterpriseManagement.ConfigurationReaderException: The service type 'Microsoft.EnterpriseManagement.Runtime.ITaskRuntimeService, Microsoft.EnterpriseManagement.Runtime, Culture="", PublicKeyToken="31bf3856ad364e35", Version="7.0.5000.0"' for the component named 'TaskService' cannot be found.at SquaredUp.Connector.Scom.Authorization.ScomConnectivityTest.GetGroupName(IImpersonation identity)at SquaredUp.Connector.Scom.Authorization.ScomConnectivityTest.Authorize(IImpersonation identity)

Cause

The problem appears to be with loading the SCOM SDK binaries from the Global Assembly Cache if the server has ever had any SCOM components installed on it (e.g. Reporting, Web Console)

Workarounds

  • Remove the SCOM Reporting Server component
  • Re-install the SCOM Web Console component if previously installed but has been removed
  • Install SquaredUp DS on a server without the SCOM components

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