Troubleshooting users being unable to logon
No license available. There are either insufficient named user licenses available, or you have been blocked from logging on to this server
No license available. There are either insufficient named user licenses available, or you have been blocked from logging on to this server.
This message means that either:
- The user trying to log on has been blocked from accessing SquaredUp DS.
or
- The maximum number of named users has been reached and therefore this user has been declined a license.
In SquaredUp DSclick on the right-hand menu ☰ > system > named users. Check if this user has been blocked, or if they are listed as a licensed user, and how many named users are available.
If you do not see the number of named users you expected see the FAQ and Troubleshooting section of How to manage Named Users.
If you see a message similar to the above, but in a tile on the page when using SquaredUp DS see There are no licenses available, or the license for this user is in use elsewhere.
Username or password incorrect
This message means that either:
- The username entered does not exist in Active Directory.
or
- If the username is correct, they have entered the wrong password.
Check Active Directory Users and Computers for this user.
Users are unexpectedly logged out or see "Your session has expired"
Your session has expired. Please refresh the page and try again
A user can roam across devices, but cannot connect from more than one device simultaneously. A user can have SquaredUp DS open in several browser tabs on the same device at the same time, but cannot access SquaredUp DS from multiple different browsers at the same time.
If the same user logs in a second time elsewhere, the message There are no licenses available, or the license for this user is in use elsewhere will be displayed on the dashboards of the first session, because the Named User license for this user has been allocated to the second session.
HTTP Error 500
Symptoms
Users see a black screen and one of various HTTP Error 500 when trying to access SquaredUp DS, and when checking the SquaredUp DS log files you see:
HTTP Error 500 (Dynamic)
Authentication/index : System.Web.HttpException
"The file {filename} has not been pre-compiled, and cannot be requested"
Possible HTTP Error 500 black screen messages:
HTTP Error 500 (Dynamic)
"The file {filename} has not been pre-compiled and cannot be requested"
HTTP Error 500 (Static)
"This error is triggered by ASP.NET and likely indicated a configuration problem rather than a runtime error in SquaredUp itself"
HTTP Error 500 (Dynamic)
OpenAccess/Index : System.Web.HttpException
"The file '/SquaredUp/Views/OpenAccess/Index.cshtml' has not been pre-compiled, and cannot be requested"
Procedure
The issue can be resolved using the following steps.
- In IIS stop the SquaredUp DS application pool.
- On the SquaredUp Server open the following folder:
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\SquaredUp[version number]
- Delete the folder within it which is named with a randomly generated GUID.
- Start the SquaredUp DS application pool. If you check you should see a new randomly named folder has been created as the SquaredUp DS assemblies are re-copied into the new folder.
- Browse to SquaredUp DS. The web page should open successfully and you should be able to log in.
Unable to log in post SquaredUp DS v4.4
Error Message on logon screen
Unable to log in after an upgrade or a new install of SquaredUp DS v4.4 and above, you may get one of the following messages:
"An unknown error occurred when logging in"
or
"Datasource authorization unsuccessful"
Error Message in the log files
The SquaredUp DS rolling.log
file includes the following (for help see Where to find log files):
YYYY-MM-DD HH:MM:SS.xxx >> XXX >> [ERR] SCOM connectivity error: unknown or non-specific errorMicrosoft.EnterpriseManagement.ConfigurationReaderException: The service type 'Microsoft.EnterpriseManagement.Runtime.ITaskRuntimeService, Microsoft.EnterpriseManagement.Runtime, Culture="", PublicKeyToken="31bf3856ad364e35", Version="7.0.5000.0"' for the component named 'TaskService' cannot be found.at SquaredUp.Connector.Scom.Authorization.ScomConnectivityTest.GetGroupName(IImpersonation identity)at SquaredUp.Connector.Scom.Authorization.ScomConnectivityTest.Authorize(IImpersonation identity)
Cause
The problem appears to be with loading the SCOM SDK binaries from the Global Assembly Cache if the server has ever had any SCOM components installed on it (e.g. Reporting, Web Console)
Workarounds
- Remove the SCOM Reporting Server component
- Re-install the SCOM Web Console component if previously installed but has been removed
- Install SquaredUp DS on a server without the SCOM components
Authentication with the System Center Operations Manager server was unsuccessful
Symptoms
A user sees the following message when trying to logon:
"Authentication with the System Center Operations Manager server was unsuccessful"
Overview
This message means that either:
- The user trying to log on is not a SCOM user and is therefore unable to authenticate against the SCOM SDK.
or
- The SCOM server specified is incorrect or inaccessible and therefore SquaredUp DS cannot communicate with the SCOM SDK.
Procedure
If others users can log in:
Check that this user is a SCOM user. Check in Active Directory Users and Computers that this user is a member of a group that has permissions to access SCOM. Commonly used roles include Administrator and Read-Only Operator, but users with other roles - such as Read-Only Operator, Operator, Advanced Operator and Author - may also log on, see Who can log on to SquaredUp DS?.
If no one can log in:
Check that the SCOM server specified is correct and that the System Center Data Access Service is running on that server:
- On the SCOM server open Server Manager > Tools > Services and right-click on the System Center Data Access Service and click start or restart. Then test again.
- Run notepad as administrator (File, Run, type
notepad
, and then right-click and select Run as administrator) and then open thescom.json
file that is in your SquaredUp DS folder in the following path:...\User\Configuration\scom.json
If you are using high availability (HA) check theThe default location for the SquaredUp folder is
C:\inetpub\wwwroot\SquaredUp
For v5 it is
C:\inetpub\wwwroot\SquaredUpv5
and for v4C:\inetpub\wwwroot\SquaredUpv4
.Name of the SquaredUp folderA custom location may have been chosen during the installation.
The default name of the SquaredUp folder is
SquaredUp
for v6 and above.For v5 it is
SquaredUpv5
, and for v4SquaredUpv4
.scom.json
on any SquaredUp server. - Update the value next to
server-address
to the correct SCOM server name, for example:"server-address": "SCOMServer01"
WhereSCOMServer01
should be replaced by your SCOM server name. - Save the file.
- Recycle the SquaredUp DS application pool in IIS in your SquaredUp server(s).
- Check that you can log in to SquaredUp DS.
Users are unexpectedly presented with the SquaredUp DS logon screen
Symptoms
- Users are logged off before the session time-out is reached (see How to configure the session time-out).
- Users are redirected to the SquaredUp DS log on page unexpectedly.
- Users may see the following message in SquaredUp DS:
Your session has expired. - You may see the following in the SquaredUp DS log files (see Where to find log files):
Stop requested: BinDirChangeOrDirectoryRename
or
Stop requested: ConfigurationChange - You may see the following in the Event Viewer Application Log:
Event message: Application is shutting down. Reason: A subdirectory in the Bin application directory was changed or renamed.
It is normal for a user to be logged out if the same user logs in elsewhere.
A user can roam across devices, but cannot connect from more than one device simultaneously. A user can have SquaredUp DS open in several browser tabs on the same device at the same time, but cannot access SquaredUp DS from multiple different browsers at the same time.
If the same user logs in a second time elsewhere, the message There are no licenses available, or the license for this user is in use elsewhere will be displayed on the dashboards of the first session, because the Named User license for this user has been allocated to the second session.
Cause
If you are load balancing SquaredUp DS you should check that the load balancer is configured to send all SquaredUp DS requests from a client session to the same SquaredUp server. You should ensure that the load balancer is configured to use 'source address affinity persistence', 'server affinity', 'session affinity' or 'persistence'. The setting name varies depending on the load balancer, for more information see Tips for using a load balancer.
When the SquaredUp DS application pool is recycled user sessions are lost, and so all users are logged off SquaredUp DS.
Some common reasons for the application pool recycling unexpectedly are:
- Anti-virus software 'touching' files
- Microsoft hotfix KB3052480 not being installed on Windows 2012 servers
Procedure
These steps will allow you to investigate unexpected recycling of the application pool further:
- Search the SquaredUp DS log files for
BinDirChangeOrDirectoryRename
. The default log file location isC:\inetpub\wwwroot\SquaredUp\transient\Log\
see Where to find log files - If you find several occurrences of
Stop requested: BinDirChangeOrDirectoryRename
then the SquaredUp DS folder needs to be added to your antivirus exclusions or exceptions list.If you are using McAfee and you are experiencing several refreshes when logging into SquaredUp DS, then you may need to implement version 8.8.07 in order to resolve this issue. Notes on this can be found here.The default location for the SquaredUp folder is
C:\inetpub\wwwroot\SquaredUp
For v5 it is
C:\inetpub\wwwroot\SquaredUpv5
and for v4C:\inetpub\wwwroot\SquaredUpv4
.Name of the SquaredUp folderA custom location may have been chosen during the installation.
The default name of the SquaredUp folder is
SquaredUp
for v6 and above.For v5 it is
SquaredUpv5
, and for v4SquaredUpv4
. - Search the SquaredUp DS log files for
ConfigurationChange
. You can find the log files in the SquaredUp DS folder in the following path:...\transient\Log
The default location for the SquaredUp folder is
C:\inetpub\wwwroot\SquaredUp
For v5 it is
C:\inetpub\wwwroot\SquaredUpv5
and for v4C:\inetpub\wwwroot\SquaredUpv4
.Name of the SquaredUp folderA custom location may have been chosen during the installation.
The default name of the SquaredUp folder is
SquaredUp
for v6 and above.For v5 it is
SquaredUpv5
, and for v4SquaredUpv4
. - If you find several occurrences of
Stop requested: ConfigurationChange
you should install Microsoft hotfix KB3052480 - If you are load balancing SquaredUp DS ensure that the load balancer is configured with sticky sessions, source IP/address affinity or persistence enabled see Tips for using a load balancer.
Further diagnostics
If you have configured anti-virus exclusions and installed Microsoft hotfix KB3052480 and users are still being logged off unexpectedly follow these steps to find out more about why this is happening:
Find the web.config
file located in the SquaredUp DS folder.
The default location for the SquaredUp folder is C:\inetpub\wwwroot\SquaredUp
For v5 it is C:\inetpub\wwwroot\SquaredUpv5
and for v4 C:\inetpub\wwwroot\SquaredUpv4
.
A custom location may have been chosen during the installation.
The default name of the SquaredUp folder is SquaredUp
for v6 and above.
For v5 it is SquaredUpv5
, and for v4 SquaredUpv4
.
web.config
file by copy and pasting the file to a different location.- Immediately after the
<system.web>
line add the following text:<healthMonitoring enabled="true"> <rules> <add name="App Lifetime" eventName="Application Lifetime Events" provider="EventLogProvider" profile="Default" minInstances="1" minInterval="00:00:00" maxLimit="Infinite"/> </rules> </healthMonitoring>
- Wait for the next unexpected logoff or application pool recycle.
- In Event Viewer > Windows logs > Application look for an event where the Source is "ASP.NET" and the Event ID is 1305.
- The description of the event should show the reason.
Please contact SquaredUp Support
Users are presented with the browser sign in screen
Symptoms
When users attempt to log on to SquaredUp DS they receive a browser-based login prompt.
The following error is logged in the SquaredUp DS log file (see Where to find log files):
[ERR] SCOM connectivity error: unauthorized System.UnauthorizedAccessException: The user does not have sufficient permission to perform the operation.
Cause
SquaredUp DS accesses SCOM using the end user's credentials. When Windows authentication is being used and SquaredUp DS is deployed on a dedicated server (not a SCOM server), the end user first authenticates with the SquaredUp server, and then the SquaredUp server impersonates the end user and authenticates with the SCOM Management Server. This requirement to authenticate a second time is known as a 'double-hop' and requires Kerberos delegation to be configured correctly.
Kerberos delegation involves complex configuration. It requires Kerberos authentication to be correctly functioning between client, web server and management server, and for configuration such as Service Principal Names (SPNs) to be configured correctly.
You may find that users logging on to SquaredUp DS on a client, who have also logged on to the browser on the SquaredUp server itself, will authenticate successfully. This is because their session can still be live on the SquaredUp server, which means it is in effect now only a one hop authentication between the client and SCOM. This can cause confusion when diagnosing the issue.
Resolution
Please follow the guide here User authentication methods for SquaredUp DS for SCOM.
And run through the Troubleshooting Kerberos article.
Support
You may also like to look at How to manage Named Users
Please contact SquaredUp Support