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    • Troubleshooting licensing and activation
    • Troubleshooting users being unable to logon
    • How to check which license key is being used
    • "No license available. There are either insufficient named user licenses available, or you have been blocked from logging on to this server"
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    • SquaredUp cannot start due to an error
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    • Duplicate SPN found - Troubleshooting Duplicate SPNs
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    • Authentication with the System Center Operations Manager server was unsuccessful
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  • Collecting diagnostic information
  • Operations Manager 2012 Data Warehouse Health Check Script
  • Where to find log files

troubleshootinguser access licensingsquaredup cannot start due to an error

SquaredUp cannot start due to an error

SquaredUp cannot start due to an error.

Startup failed for 'Extension packs'.

In the log:

[FTL] Error during startup sequence
System.InvalidOperationException: Exception during startup sequence ---> System.InvalidOperationException: Startup failed for 'Extension packs' ---> System.Data.SQLiteException
FOREIGN KEY constraint failed

Cause

There is a problem with one of the package zip files in the ..\SquaredUp\User\ReferencePackages folder.

Solution

  1. Stop the SquaredUp DS application pool.
  2. Add the following lines to the ..\SquaredUp\User\Configuration\extensionpacks.json file:
    {
    "log-level": "debug",
    "trace-all-queries": true
    }
  3. Rename the current log to .old (see Where to find log files).
  4. Start the SquaredUp DS application pool to reproduce the issue.
  5. Review the log for the line Startup failed for 'Extension Packs' and check the lines above that error for the last pack that is referenced. This will be the package file that is causing the startup failure.
    In the following example it was a pack called opslogixvmware:
    2020-12-23 11:53:20.140 >> 011 >> [DBG] DELETE FROM Pack WHERE (ID = '52bc9c4d-1910-460b-86c5-7531a2dff2eb' OR InternalName = 'opslogixvmware');
    2020-12-23 11:53:20.140 >> 011 >> [DBG] DELETE FROM Pack WHERE (ID = '52bc9c4d-1910-460b-86c5-7531a2dff2eb' OR InternalName = 'opslogixvmware');
    2020-12-23 11:53:20.140 >> 011 >> [DBG] ROLLBACK TO sqlite_dotnet_savepoint_1;
    2020-12-23 11:53:20.140 >> 011 >> [DBG] ROLLBACK;
    2020-12-23 11:53:20.142 >> 011 >> [FTL] Error during startup sequence
    System.InvalidOperationException: Exception during startup sequence ---> System.InvalidOperationException: Startup failed for 'Extension packs' ---> System.Data.SQLite.SQLiteException: constraint failed
    FOREIGN KEY constraint failed
  6. Stop the SquaredUp DS Application Pool.
  7. In the ..\SquaredUp\User\ReferencePackages folder, remove the problematic package zip file.

    The default location for the SquaredUp folder is C:\inetpub\wwwroot\SquaredUp

    For v5 it is C:\inetpub\wwwroot\SquaredUpv5 and for v4 C:\inetpub\wwwroot\SquaredUpv4.

    A custom location may have been chosen during the installation.

    Name of the SquaredUp folder

    The default name of the SquaredUp folder is SquaredUp for v6 and above.

    For v5 it is SquaredUpv5, and for v4 SquaredUpv4.

  8. Delete the squaredup.index file in ..\SquaredUp\Transient\Cache\ExtensionPacks
  9. Start the SquaredUp DS Application Pool.
  10. Remember to change "trace-all-queries": true to "trace-all-queries": false in the extensionpacks.json file and recycle the SquaredUp DS application pool.
  11. Check that you can now log in.

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